Restarting

SSH is required for remote logins on gigascale, source and the Ptolemy cluster.
CVS to source and gigascale uses SSH.

To restart ssh under Solaris 8:

  1. Become root on the console.
    Stopping the ssh daemon will kick you off if you are logged in remotely.
  2. Stop any sshd processes:
    /etc/init.d/sshd stop
    
  3. Use /usr/ucb/ps -auxgww | grep sshd to verify that all the sshd daemons have been killed. If not, then use kill on them and rerun ps
  4. Start ssh:
    /etc/init.d/sshd start
    
  5. Verify that ssh works:
    ssh -v hostname date
    

Resources

  • cxh's ssh page
  • Setting up ssh so you don't have to type in your password each time
  • Upgrading

    Yassp comes with ssh, below are instructions on upgrading:
    1. Install OpenSSL either from www.sunfreeware.com or from www.openssl.org
      ./config
      make
      make test
      make install
      
    2. Download the OpenSSH Portable version: http://www.openssh.com/portable.html or ftp://ftp5.usa.openbsd.org/pub/OpenBSD/OpenSSH/portable/
       ./configure --prefix=/usr/local/openssh-3.8p1 --sysconfdir=/etc/ssh --with-ssl-dir=/usr/local/ssl --with-pid-dir=/etc --without-zlib-version-check
      
      --with-pid-dir=/etc
      So /etc/init.d/sshd will work
      --sysconfdir=/etc/ssh
      The default is to install in /usr/local/openssh-version which is not writable by the clients
      --without-zlib-version-check
      Solaris patch 112611-02 does not update /usr/include/zlib.h, but it does update zlib. To verify that the patch is installed, run
      showrev -p | grep "Patch: 112611"
      
    3. mkdir /usr/local/openssh-3.8p1
      make
      make install
      
    4. Copy over any pre-existing keys:
      mkdir /etc/ssh
      cp /etc/ssh_* /etc/sshd_* /etc/ssh
      
    5. If /dev/random does not exist, then see the OpenSSL instructions. You will need to download ANDIrand from http://www.cosy.sbg.ac.at/~andi/ and install it:
      pkgadd -n -d ANDIrand-0.6-5.8-sparc-1.pkg
      /etc/rc2.d/S90random start
      
      and then rerun configure
    6. Usually, we keep a couple of copies of sshd around in /usr/local, so you will need to fix the links. Usually, /usr/local/ssh is a link to the latest version.
    7. Stop the sshd daemon with /etc/init.d/sshd stop or ps -auxgww | grep ssh then use kill
    8. Start it with /etc/init.d/sshd/start
    9. Use ssh -v host date to verify that the new version is running